규도자 개발 블로그

[해커랭크(Hackerrank)/30 Days of Code/파이썬3(python3)] Day 1: Data Types 본문

알고리즘/풀이

[해커랭크(Hackerrank)/30 Days of Code/파이썬3(python3)] Day 1: Data Types

규도자 (gyudoza) 2019. 3. 21. 20:28

Objective 
Today, we're discussing data types. Check out the Tutorial tab for learning materials and an instructional video!

Task 
Complete the code in the editor below. The variables , and  are already declared and initialized for you. You must:

  1. Declare  variables: one of type int, one of type double, and one of type String.
  2. Read  lines of input from stdin (according to the sequence given in the Input Format section below) and initialize your variables.
  3. Use the  operator to perform the following operations: 
    1. Print the sum of  plus your int variable on a new line.
    2. Print the sum of  plus your double variable to a scale of one decimal place on a new line.
    3. Concatenate  with the string you read as input and print the result on a new line.

Note: If you are using a language that doesn't support using  for string concatenation (e.g.: C), you can just print one variable immediately following the other on the same line. The string provided in your editor must be printed first, immediately followed by the string you read as input.

Input Format

The first line contains an integer that you must sum with 
The second line contains a double that you must sum with 
The third line contains a string that you must concatenate with .

Output Format

Print the sum of both integers on the first line, the sum of both doubles (scaled to  decimal place) on the second line, and then the two concatenated strings on the third line.

Sample Input

12
4.0
is the best place to learn and practice coding!

Sample Output

16
8.0
HackerRank is the best place to learn and practice coding!

Explanation

When we sum the integers  and , we get the integer 
When we sum the floating-point numbers  and , we get 
When we concatenate HackerRank with is the best place to learn and practice coding!, we get HackerRank is the best place to learn and practice coding!.

You will not pass this challenge if you attempt to assign the Sample Case values to your variables instead of following the instructions above and reading input from stdin.

풀이

# Declare second integer, double, and String variables.

# Read and save an integer, double, and String to your variables.

# Print the sum of both integer variables on a new line.

# Print the sum of the double variables on a new line.

# Concatenate and print the String variables on a new line
# The 's' variable above should be printed first.
print(int(input()) + i)
print(float(input()) + d)
print(s + input())

설명

자료형 문제이다. 주어진 정수형에는 정수형 자료를 더해서 출력하고 소수형에는 소수를 더해서 출력하고 문자열에는 문자를 더해서 출력하는 문제이다. 형변환 없이 때려박으면 오류가 나니까 그런 부분들에 대한 문제라고 생각하면 되겠다.

Comments